SG

SG

Rabu, 07 Desember 2011

BGP-RR

pada posting ini saya ingin membahas BGP Route-Reflector, atau biasa disebut RR
berikut contoh BGP menggunakan RR. kita ada 2 AS, AS 123 dan AS 4.
di dalam AS 123 ini kita tidak perlu membuat peering antar router didalam AS 123, tapi bisa menggunakan RR. coba kita lihat konfigurasinya :


R4
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Loopback21
 ip address 21.0.0.1 255.255.255.255

interface FastEthernet0/1
 ip address 34.34.34.4 255.255.255.0
 duplex auto
 speed auto
!
router bgp 4
 no synchronization
 bgp log-neighbor-changes
 network 4.4.4.4 mask 255.255.255.255
 network 21.0.0.1 mask 255.255.255.255
 neighbor 34.34.34.3 remote-as 123
 no auto-summary
!
ip route 3.3.3.3 255.255.255.255 34.34.34.3




R3

R3
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.3 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 34.34.34.3 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 2.2.2.2 next-hop-self
 neighbor 34.34.34.4 remote-as 4
 no auto-summary
!
ip route 4.4.4.4 255.255.255.255 34.34.34.4



R2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.23.23.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 25.25.25.2 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 23.23.23.0 mask 255.255.255.0
 network 25.25.25.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 route-reflector-client
 neighbor 3.3.3.3 remote-as 123
 neighbor 3.3.3.3 update-source Loopback0
 neighbor 3.3.3.3 route-reflector-client
 neighbor 5.5.5.5 remote-as 123
 neighbor 5.5.5.5 update-source Loopback0
 neighbor 5.5.5.5 route-reflector-client
 no auto-summary







R5
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 51.51.51.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 25.25.25.5 255.255.255.0
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 network 51.51.51.0 mask 255.255.255.0
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 1.1.1.1 route-reflector-client
 neighbor 2.2.2.2 remote-as 123
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary





R1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 51.51.51.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 123
 no synchronization
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 123
 neighbor 5.5.5.5 update-source Loopback0
 no auto-summary
!









Tidak ada komentar:

Posting Komentar